Форум VDT Industrial Automation
Потеря директории в RSViewSE 4.00.00 (CPR7) - Версия для печати

+- Форум VDT Industrial Automation (http://forum.vdt-automation.ru)
+-- Форум Системы и средства автоматизации (http://forum.vdt-automation.ru/forumdisplay.php?fid=1)
+--- Форум Аппаратные средства систем автоматизации (http://forum.vdt-automation.ru/forumdisplay.php?fid=2)
+--- Темы: Потеря директории в RSViewSE 4.00.00 (CPR7) (/showthread.php?tid=31)



Потеря директории в RSViewSE 4.00.00 (CPR7) - Alibaster - 23-Aug-2017

Добрый день.

На сервере периодически в хаотическом порядке в период 1 - 2 недели появляется одна и таже ошибка.
В Event Viewer (виндовый лог событий):
- в ветке System:
The Rockwell Application Services service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 1000 milliseconds: Restart the service. For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
- в ветке FactoryTalk Diagnostics:
(RSDbgUtils,RTE_ERROR_CRITICAL,process:RsvcHost.exe) RsvcHost experienced an unrecoverable anomaly.  Please contact Rockwell technical support.  Dump file= C:\WINDOWS\TEMP\RsvcHost\RsvcHost-20170823-003624-1660-2244.dmp

На сервере в Diagnostics Viewer в момент возникновения ошибки появляются строчки:

Server available. The FactoryTalk Directory server for scope '$Global' is now available on computer localhost.
In service. The FactoryTalk Directory server for scope '$Global' on computer localhost is now active

в одну и туже секунду, далее такие же сообщения и про остальные HMI проекты по очереди. Такое чувство, что временно теряет и находит директорию с проектом.
Клиенты которые были подцеплины к серверу, дальше продолжают работать исправно без замечаний, но если запустить  нового клиента, то клиент не может получить данные, по всему экрану появляются квадратные рамки, как при отсутствии данных. Так же когда студией пытаются подключится к какому нибудь HMI проекту, то в студии пишет сообщение об ошибке, что не может найти директорию с проектом и ничего не дает делать. Лечиться только перезагрузкой сервера. После перезагрузки все работает нормально. Кто нибудь сталкивался с таким?

На сервере установлена:
RSViewSE 4.00.00 (CPR7)
Windows Server 2003 Service Pack 2

На клиентах установлена:
RSViewSE 4.00.00 (CPR7)
Windows XP Service Pack 3

На студии (стоит на отдельном компьютере):
RSViewStudio 4.00.00 (CPR7)
Windows XP Service Pack 3


RE: Потеря директории в RSViewSE 4.00.00 (CPR7) - Ryzhij_62 - 24-Aug-2017

Убедитесь, что IP-адреса всех ваших машин действительно статические, а, например,  не раздаются роутером через DHCP.


RE: Потеря директории в RSViewSE 4.00.00 (CPR7) - Alibaster - 25-Aug-2017

(24-Aug-2017, 10:16:47)Ryzhij_62 Написал: Убедитесь, что IP-адреса всех ваших машин действительно статические, а, например,  не раздаются роутером через DHCP.

Все IP у нас статические


RE: Потеря директории в RSViewSE 4.00.00 (CPR7) - Ryzhij_62 - 25-Aug-2017

И нормально пингуются при возникновении проблемы?


RE: Потеря директории в RSViewSE 4.00.00 (CPR7) - Alibaster - 25-Aug-2017

(25-Aug-2017, 16:15:29)Ryzhij_62 Написал: И нормально пингуются при возникновении проблемы?

Пингонуть попробую при возникновении, только кого пинговать? директорию где лежит сам проект?


RE: Потеря директории в RSViewSE 4.00.00 (CPR7) - Alibaster - 28-Aug-2017

Пинги нормально все идут, с клиентов до сервака, до директории, с директории до сервера.
У нас 2 сервера, почти одинаковая конфигурация, на одном директория с проектами вынесена на отдельную машину, на другом директория находится на самом сервере SE.
Там где директория находится вместе с сервером SE проблема возникает описанная выше, а на другом где директория находится отдельно от сервера SE, при возникновении ошибки все восстанавливается нормально, т.е. ошибка проходит, связь с директорией теряется на секунду и восстанавливается обратно. Проблема видать с локальной директорией. Попробуем создать на втором сервере отдельную директорию.